Can't add more one bike


#1

i’ve had one bike listed for some time. got an additional one but everytime i try to register it the site directs me to an option to edit the one that’s already listed. so far i’ve seen no way to list more than one. any help would be appreciated


#3

I’m having the same issue. I have two existing bikes registered and am trying to register a third. I had already tried both of the above methods. Seems like something is causing the server to return the wrong page, maybe for only some users?

@Steve_Piercy It’s not clear from your reply if this was something you tried yourself and whether it worked for you, or if you’re simply suggesting ways to do this. Can you clarify?


#4

I’ve opened an issue in the GitHub repo to see if the developers have some insight.


#6
  • login
    -your bikes
  • add new bike
  • with add my bike checked i click register new bike
  • i’m met with the bike i already have registered and a blue banner saying “whoa this cool bike is yours”…no way to add additional bike but merely edit the one i already have registered. (chrome on a mac; if that helps)

#8

Following the link yields the same result for me. And I’ve tried from both my Mac comp and my Android phone now


#9

and just now tried after logging in with a pc at work. same result “cool bike” with an edit option


#10

Hmmmm. This is weird.

I’ve tried to replicate what you’re running into and can’t - I register a new bike without an issue. I created a new account and with that new account, I successfully registered two bikes without a problem.

But since you’re both experiencing the issue, it seems unlikely that it’s just a weird cache issue or something you’re doing wrong.

I’ve replied in the github issue, I’ll update here if I figure out what is causing this


#11

Ha! Figured it out.

It turns out that this was an issue that happened because both of you have been Bike Index users for a long time (thank you!). We changed part of the format (in the commit that you pointed out @Brandon_Evans in GitHub), which works perfectly for new users and new bikes being created - but since you have some weird data floating around from signing up years ago, it broke.

I’m fixing it now.

Thanks for saying something @zak_graham !


#12

This should be fixed @zak_graham and @Brandon_Evans

It would be great if one or both of you could verify that it works correctly and respond here.

Thanks again, to all of you - @Steve_Piercy as well for attempting to get to the bottom of this :slight_smile:


#13

Works for me now! :tada: Thanks @Steve_Piercy and @seth for digging into this so quickly!