[Dev] Cannot authorize OAuth endpoint

I need some help setting up Callback URLs for an application I’d like to develop. I edited the application configuration to add callback URLs for 1) the documentation page, 2) the provided-URL for localhost, and 3) my application’s callback.

Starting on the bike index.org/oauth/applications/#id page, I click “Authorize” to the URL for the documentation pages. The URL that opens is https://bikeindex.org/oauth/authorize?client_id=[redacted]&redirect_uri=https%3A%2F%2Fbikeindex.org%2Fdocumentation%2Fauthorize&response_type=code.

The problem is that every callback URL I try all fail with this same error message about an absent scope. The page that opens displays:

Missing required parameter: scope.

I’ve tried finding available scopes from the GitHub repo and adding those to the URLs, but I think this problem requires the dev page /oauth/authorize query parameters to include the scope.

Oooh, good catch at @Jack093478 - that Authorize button doesn’t work.

If you go from the documentation page, you get a list of checkbox to select scopes:

The available scopes are: read_user, write_user, read_bikes, write_bikes, read_organization_membership, write_organizations

I am updating that authorize button to be valid

1 Like

Thank you! That fixes the authorize button for http URLs and the out-of-band url for local tests.

Is clicking Authorize a required step before developing native apps with their own deeplink callback URLs (that browsers can’t open) — or can I just proceed with development now that the my deeplink is listed in the callbacks?

You can proceed with developing a native app!

If you run into trouble or it doesn’t work, please give a shout.